C++ coding style

Opinions differ in detail, but here is guidance from two experts. I have left out some passages that do not apply in this course.

Linus Torvalds

This is based on Linus Torvalds' "Linux kernel coding style" document. Torvalds is the Man behind Linux.
	 	Chapter 1: Indentation

Rationale: The whole idea behind indentation is to clearly define where
a block of control starts and ends.  Especially when you've been looking
at your screen for 20 straight hours, you'll find it a lot easier to see
how the indentation works if you have large indentations. 

Now, some people will claim that having 8-character indentations makes
the code move too far to the right, and makes it hard to read on a
80-character terminal screen.  The answer to that is that if you need
more than 3 levels of indentation, you're screwed anyway, and should fix
your program. 

In short, 8-char indents make things easier to read, and have the added
benefit of warning you when you're nesting your functions too deep.
Heed that warning.


		Chapter 3: Placing Braces

The other issue that always comes up in C styling is the placement of
braces.  Unlike the indent size, there are few technical reasons to
choose one placement strategy over the other, but the preferred way, as
shown to us by the prophets Kernighan and Ritchie, is to put the opening
brace last on the line, and put the closing brace first, thusly:

	if (x is true) {
		we do y
	}

Note that the closing brace is empty on a line of its own, _except_ in
the cases where it is followed by a continuation of the same statement,
ie a "while" in a do-statement or an "else" in an if-statement, like
this:

	do {
		body of do-loop
	} while (condition);

and

	if (x == y) {
		..
	} else if (x > y) {
		...
	} else {
		....
	}
			

		Chapter 4: Naming

C is a Spartan language, and so should your naming be.  Unlike Modula-2
and Pascal programmers, C programmers do not use cute names like
ThisVariableIsATemporaryCounter.  A C programmer would call that
variable "tmp", which is much easier to write, and not the least more
difficult to understand. 

HOWEVER, while mixed-case names are frowned upon, descriptive names for
global variables are a must.  To call a global function "foo" is a
shooting offense. 

GLOBAL variables (to be used only if you _really_ need them) need to
have descriptive names, as do global functions.  If you have a function
that counts the number of active users, you should call that
"count_active_users()" or similar, you should _not_ call it "cntusr()". 

Encoding the type of a function into the name (so-called Hungarian
notation) is brain damaged - the compiler knows the types anyway and can
check those, and it only confuses the programmer.  No wonder MicroSoft
makes buggy programs. 

LOCAL variable names should be short, and to the point.  If you have
some random integer loop counter, it should probably be called "i". 
Calling it "loop_counter" is non-productive, if there is no chance of it
being mis-understood.  Similarly, "tmp" can be just about any type of
variable that is used to hold a temporary value. 

If you are afraid to mix up your local variable names, you have another
problem, which is called the function-growth-hormone-imbalance syndrome. 
See next chapter. 

		
		Chapter 5: Functions

Functions should be short and sweet, and do just one thing.  They should
fit on one or two screenfuls of text (the ISO/ANSI screen size is 80x24,
as we all know), and do one thing and do that well. 

The maximum length of a function is inversely proportional to the
complexity and indentation level of that function.  So, if you have a
conceptually simple function that is just one long (but simple)
case-statement, where you have to do lots of small things for a lot of
different cases, it's OK to have a longer function. 

However, if you have a complex function, and you suspect that a
less-than-gifted first-year high-school student might not even
understand what the function is all about, you should adhere to the
maximum limits all the more closely.  Use helper functions with
descriptive names (you can ask the compiler to in-line them if you think
it's performance-critical, and it will probably do a better job of it
that you would have done). 

Another measure of the function is the number of local variables.  They
shouldn't exceed 5-10, or you're doing something wrong.  Re-think the
function, and split it into smaller pieces.  A human brain can
generally easily keep track of about 7 different things, anything more
and it gets confused.  You know you're brilliant, but maybe you'd like
to understand what you did 2 weeks from now. 


		Chapter 7: Commenting

Comments are good, but there is also a danger of over-commenting.  NEVER
try to explain HOW your code works in a comment: it's much better to
write the code so that the _working_ is obvious, and it's a waste of
time to explain badly written code. 

Generally, you want your comments to tell WHAT your code does, not HOW. 
Also, try to avoid putting comments inside a function body: if the
function is so complex that you need to separately comment parts of it,
you should probably go back to chapter 4 for a while.  You can make
small comments to note or warn about something particularly clever (or
ugly), but try to avoid excess.  Instead, put the comments at the head
of the function, telling people what it does, and possibly WHY it does
it. 
================================================================

Geoff Kuenning

Comments

Writing good comments takes practice. However, it is a critical skill to acquire. It will make your code much easier to read, both for you and for other people. It will also help you get as many points as possible, especially for code that does not fully work.

Code style

Significantly fewer comments are required if you use good coding style:

Function names can be very long and English-like, e.g. read_input_file, compute_standard_deviation. Variable names are typically shorter e.g. infile, sum, count, num_vars, max_length.

Only use very short, generic variable names (e.g. x, y, i, j, ptr) in contexts where their purpose is obvious. For example, i and j are often used as indices for loops; x and y are often used as coordinates in geometrical or graphical algorithms.

Don't use a variable for one purpose (e.g. a loop index) and then reuse it later for another purpose (e.g. to store a count).

Comments at the start of the file

At the start of the file, there should be a long block of comments containing:

Long comments in the code

There should be longish comments (e.g. 1-5 lines):

These commends should explain what the next piece of code does. Comments before a function should explain what inputs it expects and what outputs it returns.

Focus on how this code fits into the overall algorithm (e.g. "reads the database from the input file"). Comment things that might not be obvious to the reader.

Don't comment obvious things such as how many parameters a function takes, or numerical parameters whose names clearly indicate their purpose (e.g. xsize and ysize in a 2D array allocator), or the main goal of a function with a self-explanatory name like compute_standard_deviation.

Short comments in the code

There should be short comments (e.g. partial line)

If you can't explain an obscure piece of code with comments at the ends of lines, put a longer multi-line comment at the nearest convenient place above the obscure code.

Report

Your documentation should describe

The main subject of the documentation should be the code. If it starts sounding like a short story about you, rephrase to make it focus more on the code.

If you could not get your approach to work, it is appropriate (and will probably get you more points) to describe how your approach was supposed to work.

If something doesn't work, say so. If a piece of code seems like a kludge (ugly hack), say so. The reader will eventually notice the problem anyhow: stating it explicitly saves them work and makes it clear that you saw the problem.


M.S. Colclough, 2001-2010